Question

Q: Microsoft Windows Server DNS Zone NSLookup Warning

I'm receiving alerts after importing the DNS management pack, version 10.0.6.0 regarding all my DNS zones not being monitored correctly due to an Internal-Script Error. Each zone is hosted on a Windows Server 2012 R2 domain controller running DNS and all are reporting the same alert. See screenshots below:



Dear Partner,

Thanks for your post. This is Matthew and I am glad to assist you.

From your description, I learned that we received alerts after importing the DNS management pack. If I misunderstood anything, please feel free to let me know.

Before we start, could you please help me confirm the version of the SCOM?

Meanwhile, for this issue, I need some more time do some more research and we will update to you as soon as possible. Thanks for your time and understanding.

Best regards,

 

Matthew Lu

Microsoft Partner Support Community Technical Support Engineer

Microsoft Global Partner Services

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Hi Partner,

 

Thank you for your patience. This is Matthew’s co-worker Alex.

 

If I understand correctly, if we scroll down the alert details, we will see the below message as described in this article, right?

 

Causes

NSLOOKUP failed to resolve the zone name.

 

Resolutions

Ensure that the zone is started, and that the DNS service is started.

 

Just to confirm you, besides the alert, is there any actual impact in the environment? In addition, have we tried the resolutions mentioned above?

 

If anything is unclear, please feel free to let me know.

 

Best regards,

 

Alex Zhu

Microsoft Partner Support Community Technical Support Engineer

Microsoft Global Partner Services

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Thanks for the responses. The management server version is: 7.2.11719.0 and the client agents are: 8.0.10918.0

Yes - that is the correct monitor. I feel like it's something with the script syntax that's causing the lookup error. The environment is working correctly and all DNS records are present. If I try to run the command manually that I see reported in the health explorer "chcp 437 && NSLookup.exe -timeout=10 -querytype=NS DNSZoneName.com. 127.0.0.1" on the server being monitored I get the following response: "The token '&&' is not a valid statement separator in this version." Not sure if that's related?

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Hi Partner,

 

Thank you for your reply.

 

Based on my checking, it seems we use PowerShell script to verify the DNS server function and we issued two commands in one line (use && to connect them, however, it is not recognized). If possible, we can try the use ; to write two commands in one single line or in two lines to see if we can eliminate the phenomenon.

 

chcp 437; NSLookup.exe -timeout=10 -querytype=NS DNSZoneName.com. 127.0.0.1

 

If anything is unclear, please feel free to let me know.

 

Best regards,

 

Alex Zhu

Microsoft Partner Support Community Technical Support Engineer

Microsoft Global Partner Services

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Thanks for the reply, Alex. Is this something I have the ability to modify as the script is part of the sealed management pack?

Thanks!

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Hi Partner,

 

Thank you very much for the clarification.

 

It seems this may relate to the products feature. For such kind of query, I will try the best to deliver the information to the product team to see if they have any comments, but not guaranteed. If there is any update, I will get back to you at earliest time. Thanks for your great patience in advance.

 

If anything is unclear, please feel free to let me know.

 

Best regards,

 

Alex Zhu

Microsoft Partner Support Community Technical Support Engineer

Microsoft Global Partner Services

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Hi Alex,
This is indeed caused by the change to a powershell and you found the issue already with the double ampersand. If run manually from a powershell prompt your version with the semicolon in it in place of double ampersand it works again. Can you bring this feedback to the product team so they quickly change this and raise the pack version or make the download for the previous version of the pack available again.
Have the same at a customer now generating over a thousand alerts.
Thanks,
SCOM-Bob MVP

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Hi Bob,

 

Thank you very much for the clarification.

 

Actually, we’ve already forwarded the information to the product team and waiting for their response if there is any. Hope this can be solved soon. If they have any comments, I’ll get back to you immediately. Thanks for your kind understanding again.

 

If anything is unclear, please feel free to let me know.

 

Best regards,

 

Alex Zhu

Microsoft Partner Support Community Technical Support Engineer

Microsoft Global Partner Services

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This posting is provided "AS IS" with no warranties, and confers no rights

Did this solve your problem?

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Question Info

Views: 548 Last updated: July 11, 2018 Applies to: